Google Ads - Delayed downloads

Incident Report for Funnel

Resolved

All affected sources have returned to normal operations.
Posted Aug 27, 2025 - 12:14 CEST

Monitoring

Some users may be experiencing delays with data downloads for Google Ads sources.

A fix has been deployed, and we are monitoring the situation as the systems return to normal.
We apologize for any inconvenience this may have caused.
Posted Aug 26, 2025 - 11:59 CEST