AppsFlyer - Data Mismatch

Incident Report for Funnel

Monitoring

AppsFlyer - Inflated monetary values
Monitoring - A recent update to our AppsFlyer connector caused a regression that greatly inflated monetary values, specifically Cost and Event Revenue, for any data that the connector retrieved between March 16th 10:05 AM and March 17th 12:04 AM (both times UTC). A fix has been deployed, and we believe that the majority of affected AppsFlyer data sources should self-heal within 24 hours.

If your data source is still showing inflated values for these metrics after 24 hours, or if you want us to manually refresh your data source(s) to expedite the process of getting your data corrected, please reach out to our support team. We apologize for the inconvenience.
Posted Mar 17, 2026 - 16:05 CET