Facebook Ads - Reach and frequency reports with Lifetime time window delayed

Incident Report for Funnel

Resolved

This incident has been resolved.
Posted Dec 20, 2024 - 14:08 CET

Identified

This issue has been acknowledged by Meta and escalated internally by their support team.
Posted Aug 16, 2024 - 11:11 CEST

Investigating

As of August 12 we have noted that a number of Reach and frequency reports are delayed in their downloads. The issue appears to be in Meta's API and we are cooperating with them to find the root cause.
Posted Aug 14, 2024 - 10:22 CEST