Delayed downloads for Facebook Ads
Incident Report for Funnel
Monitoring
We have released a change that we hope will start to remediate this issue.

Unfortunately it will take some time to start showing results and we expect the job delays to continue throughout the day.
We are monitoring the effects of our change and will update as soon as we have news.
Posted Nov 20, 2024 - 10:20 CET
Identified
We are currently encountering limitations due to Facebook API quotas. This may result in temporary delays or reduced functionality as we approach or exceed usage thresholds.

Our team is actively monitoring usage and working to minimize disruptions. We appreciate your understanding and patience as we work within these limits.

We will provide daily updates as we work to resolve this issue.
Posted Nov 20, 2024 - 09:14 CET