Meta Related Connectors - Delayed Downloads

Incident Report for Funnel

Resolved

Our team has identified the issue and released a fix. This issue is now resolved.
Posted Jul 03, 2024 - 14:52 CEST

Investigating

We are experiencing delays in downloads for Facebook Ads, Facebook Pages and Instagram connectors. Our team is currently investigating the issue.
Posted Jul 02, 2024 - 11:44 CEST