The Trade Desk – Download delays

Incident Report for Funnel

Resolved

The issue is resolved. The reports we schedule finish successfully, so data sources are managing to import new data once again.
Posted Jul 22, 2025 - 10:03 CEST

Update

We have now reached out to our contacts at The Trade Desk, waiting for their reply.
Posted Jul 21, 2025 - 12:08 CEST

Investigating

We have noticed elevated error rates for The Trade Desk data sources, beginning around 7:00 CEST yesterday (July 20th). The reports that we schedule through the TTD API appear to get stuck and never finish, causing delays.

We are reaching out to The Trade Desk for further investigation.
Posted Jul 21, 2025 - 11:42 CEST