Snapchat seem to have rolled back the changes on their side. Data sources previously affected by this problem are now managing to download new data successfully.
We are waiting to receive confirmation from Snapchat on what actions they have taken, and which adjustments (if any) we should make to our connector to ensure this issue does not happen again. We will continue to monitor the connector closely until we hear back from Snapchat.
Posted Jan 15, 2026 - 10:22 CET
Identified
We are in talks with a representative from Snapchat on how to proceed in this case. Additionally, we have received more specifics on the issue itself, namely that metrics related to Subscriptions are incompatible with the Country dimension.
Previously, this incompatibility would simply return a metric value of 0 for affected metrics, however this behavior has now been altered to raise an error instead, resulting in the issue we are trying to resolve here.
We are now looking into updating our integration to exclude Subscription-related metrics when a data source has been configured to use Country as its dimension to accommodate this new API behavior.
Posted Jan 14, 2026 - 17:08 CET
Investigating
We have observed that many Snapchat data sources are currently experiencing issues with importing new data. This appears to relate to a particular metric, conversion_subscribe (or "Subscriptions"), that the Snapchat API has suddenly started treating as incompatible when included in our requests.
We have reached out to Snapchat's developer support to get insights on what the problem is. Should the issue continue to persist, we will consider temporarily removing the metric in question in order to get affected data sources up and running again.