Data Explorer Not Loading

Incident Report for Funnel

Resolved

After careful monitoring and no recent reports of the Data Explorer not loading, the issue is now resolved.
Posted Jul 15, 2025 - 15:39 CEST

Monitoring

The team has identified the issue and the Data Explorer tool should be loading again properly. We'll continue to monitor the progress of the update and follow up with more information as soon as we have more insights to share
Posted Jul 14, 2025 - 20:08 CEST

Investigating

We have recently received reports from users that the Data Explorer is no longer loading. Our team is currently investigating the issue and will continue to post updates as soon as we have more information.
Posted Jul 14, 2025 - 19:39 CEST