X Ads and X Organic data sources in Delayed state for Subset of report types

Incident Report for Funnel

Update

We are continuing to work on a fix for this issue.
Posted Apr 13, 2026 - 15:06 CEST

Identified

We have identified an issue where X endpoints we are using for specific reports are not returning data.
Our hypothesis is that this is due to the major update on X Ad platform.

Sources with the issue:
X Ads
- All configuration except Campaign Non-Agg
X Organic
- Tweet Activity (User insights is working)

The issue has been reported by multiple other vendors.
The issues started 2026-04-10.

We are working on findings ways around the issue.
See also related Status page X Ads - Missing data since 26 March https://status.funnel.io/incidents/dsyj3s7hzrzf
Posted Apr 11, 2026 - 13:33 CEST