Facebook Ads sources delayed with "Service temporarily unavailable".

Incident Report for Funnel

Update

We've identified that this issue specifically affects data sources configured with the Country breakdown. Sources without this breakdown are downloading normally.

Workaround: If the Country breakdown is not essential for your reporting, you can connect a new data source without it applied to resume data imports.

We are in contact with Meta regarding this issue and will provide another update as soon as we have more information.
Posted May 22, 2026 - 13:25 CEST

Update

We are continuing to investigate this issue.
Posted May 22, 2026 - 13:24 CEST

Investigating

We are aware of this issue and in contact with Meta support.

We have been receiving "Service temporarily unavailable" from the Facebook Ads API since the 16th of May.

We will keep updating you on this status page.

Thank you for your patience.

/Funnel Team
Posted May 21, 2026 - 13:04 CEST