All affected Trade Desk data sources have now fully recovered, and data imports are operating normally. The issue was caused by a recent connector update that impacted API performance. The update has been reverted, and we have validated that imports are completing as expected. We will continue to monitor performance closely to ensure ongoing stability.
Posted Mar 06, 2026 - 15:53 CET
Monitoring
The issue affecting some Trade Desk data sources has been corrected.
We identified that a recently added field in the connector impacted API performance, preventing some data imports from completing. The field has been removed, and delayed sources are now recovering.
We are continuing to monitor to ensure stable data delivery.
Posted Mar 06, 2026 - 09:42 CET
Investigating
We have received reports of Trade Desk data sources and the imports of their most recent data being delayed. The team is currently investigating the issue and will provide further updates on the data delays as soon as we have them. We appreciate your patience while investigating the issue.