Salesforce data sources — increased authentication errors

Incident Report for Funnel

Monitoring

We have deployed a fix that resolves authentication errors for the majority of affected Salesforce sources.

For most users: reconnecting your Salesforce data source through the Funnel UI will restore access and resume data collection. We recommend doing this if your source is currently showing "No Access."

For a subset of users: we are aware that the reconnection flow is not completing successfully in some cases. We have identified this as a separate issue and are actively working to resolve it. No action is required from affected users at this time, we will provide an update as soon as a resolution is in place.

We continue to monitor all Salesforce connections closely.
Posted May 15, 2026 - 17:30 CEST

Investigating

Due to mandatory security updates required by Salesforce, we recently enabled stricter token security controls across our Salesforce connectors (Marketing Cloud not affected)

We are seeing an increased number of Salesforce sources reporting authentication errors ("No Access"). This is caused by existing refresh tokens being invalidated as part of the Salesforce security rollout. Affected sources need to be reconnected to generate a new valid token.

We are also currently investigating issues with the reconnection flow that may prevent some users from completing the reconnect. We are working to unblock this with highest priority.
Posted May 12, 2026 - 20:25 CEST