Issues with Facebook and Instagram sources

Incident Report for Funnel

Monitoring

Facebook appears to have implemented a fix on their side. We've had recent reports of users successfully connecting their Facebook and Instagram data sources, and new connections should now be working. We'll continue to monitor the situation but believe the issue should be resolved at this point in time.
Posted Jun 12, 2026 - 18:17 CEST

Investigating

There's an issue currently originating from Meta, which affects their services. Once the issue is resolved on Meta's side, the connection of new Facebook and Instagram sources will be possible again.

Feel free to follow along and monitor the progress of the incident on Facebook's official status page here: https://metastatus.com/ads-manager
Posted Jun 12, 2026 - 16:15 CEST