Google Ads - Inflated numbers
Incident Report for Funnel
Resolved
There have been no further customer reports of the issue occurring after the most recent update. The issue is now resolved.
Posted Jun 07, 2024 - 18:22 CEST
Update
Affected Google Ads sources have now refreshed with the correct data. We will keep monitoring the situation.
Posted Jun 05, 2024 - 09:58 CEST
Update
As of Monday morning we have received reports of some Google Ads data sources still experiencing the inflated numbers issue from last week.

To solve the issue our development team has made some changes around how we cache the imported data for Google Ads data sources. This fix might result in temporarily inflated numbers until the cache is emptied. All data sources should be operating as normal by tomorrow, Tuesday June 4th at 12pm CET.
Posted Jun 03, 2024 - 18:46 CEST
Monitoring
A fix is now in place and sources is have no inflated numbers. We are monitoring all sources to see that everything proceeds as intended.
Posted May 21, 2024 - 11:18 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2024 - 15:36 CEST
Investigating
There is an error in production resulting in inflated data for sources with standard report on Ad level. The Error is identified and removed, we are in the process to correct the inflated numbers.

We will keep you updated on a daily basis, and when the problem is resolved.
Posted May 20, 2024 - 15:36 CEST