Amazon Ads - Download delays

Incident Report for Funnel

Resolved

Everything is back to normal, seems like it was a temporary issue.
Posted Feb 18, 2025 - 08:52 CET

Investigating

We are currently experiencing issues with our downloads from Amazon Ads, affecting a lot of our data sources. It seems like Amazon Reporting API might have some server issues on their side. We don't know anything about it at the moment but we will investigate.
Posted Feb 17, 2025 - 16:07 CET