X Ads + Organic – Connect issues
Incident Report for Funnel
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 10:53 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2024 - 10:04 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 12, 2024 - 19:20 CET
Investigating
There is currently an issue preventing users from connecting new sources or reconnecting existing sources using the X Ads and X Organic core connectors. We are investigating.
Posted Mar 12, 2024 - 19:08 CET