We’re continuing to monitor the ongoing AWS incident. While we’re seeing gradual recovery, Funnel services are not yet performing as expected.
Downloads and exports have started to recover, but some users may still experience delays or errors in the app.
Our team is closely tracking the situation and working to restore full functionality as soon as possible.
Posted Oct 20, 2025 - 16:03 CEST
Update
AWS is reporting continued signs of recovery:
“We continue to observe recovery across most of the affected AWS services. Global services and features that rely on US-EAST-1 have also recovered. We continue to work towards full resolution and will provide updates as we have more information to share.”
As systems stabilize, some Funnel processes may still experience degraded performance, including:
- Access to the Funnel app - Scheduled exports - Retrieval of new data
Our team is actively working to restore full performance as quickly as possible. We appreciate your patience as services return to normal.
Posted Oct 20, 2025 - 12:28 CEST
Monitoring
Earlier today, Funnel experienced a period of complete downtime due to a widespread AWS service disruption in the US-EAST-1 region, which impacted multiple AWS services including DynamoDB: https://health.aws.amazon.com/health/status
As a result, the Funnel app was unavailable for approximately two hours.
AWS has since implemented mitigations and reports that most services are recovering. Funnel is now operational again, but you may continue to experience some delays in data source updates and data exports as systems work through remaining backlogs.
We are closely monitoring the situation and continuing to do everything we can to bring Funnel back to its normal performance. We’ll post further updates here as recovery progresses.
We sincerely apologize for the inconvenience and appreciate your patience while we ensure everything is fully restored. (edited) No components were marked as affected by this incident.