Facebook Ads incomplete data - zero metric values

Incident Report for Funnel

Resolved

We’re now closing this incident, as everything has been running smoothly since yesterday.

The root cause was an update to one of our supporting libraries, which led to incorrect data being shown for a period of time. We’re adding additional safeguards and monitoring to reduce the risk of this happening again.

We sincerely apologize for any inconvenience this may have caused. We know that you rely on Funnel to make confident marketing decisions, and our commitment is that your data should always be available, accurate, and trustworthy. We fell short of that expectation in this case, and we appreciate your patience while we resolved the issue.

Thank you for your understanding.
Posted Jan 23, 2026 - 13:54 CET

Monitoring

We identified the issue as a change in Funnel’s query engine that was released at 10:00 AM CET (04:00 AM EST, 01:00 AM PST). The change was rolled back at 2:00 PM CET (08:00 AM EST, 05:00 AM PST).

While the change was live, incorrect metrics were produced across Funnel dashboards, Data Explorer, and data exports.
As a result, any data exports generated during this period may contain incorrect metric values.

The data will be corrected automatically on the next scheduled export, or you may choose to manually re-run exports to correct the data sooner.

We are keeping the incident open and under monitoring for a period of time to ensure that metrics remain stable and that no further issues occur.
Posted Jan 22, 2026 - 14:50 CET

Identified

We have identified a potential issue introduced. Working on rolling back issue.
Posted Jan 22, 2026 - 13:51 CET

Investigating

We are investigating a issue where Facebook Ads gets incorrect data. It shows up as zeroes in metric values.

Incident will be updated continuously.
Posted Jan 22, 2026 - 13:22 CET
This incident affected: Funnel.