Facebook Ads - Delayed Downloads
Incident Report for Funnel
Resolved
This incident has been resolved.
Posted Jun 10, 2024 - 10:28 CEST
Investigating
We are seeing an increased rate of errors for our Facebook Ads connector. This might result in some delays in the downloads for your Facebook Ads data sources. We are investigating the issue and will update the status page as we learn more.
Posted Jun 07, 2024 - 18:15 CEST