Facebook Ads - Download delays due to quota issues

Incident Report for Funnel

Resolved

This incident has been resolved.
Posted Apr 18, 2024 - 10:43 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2023 - 11:06 CET

Investigating

We are investigating this issue.
Posted Oct 30, 2023 - 11:49 CET