X Organic – Data mismatches (Video metrics)
Incident Report for Funnel
Resolved
This incident has been resolved.
Posted Oct 03, 2023 - 13:26 CEST
Monitoring
Organic video metrics are still unavailable. We are awaiting a response from Twitter API support regarding the availability and retrieval of these metrics.
Posted Jun 12, 2023 - 17:36 CEST
Update
This issue is not yet resolved for video metrics. Non-video metrics, such as impressions, are being fetched correctly.
Posted Jun 09, 2023 - 10:14 CEST
Update
When investigating this we have found that the mismatches appear to be related to fetching video metrics. We will temporary stop fetching video metrics for the Twitter Organic Tweet Activity report. This should ensure that non-video metrics, such as impressions, will match.

We will continue to investigate the issue.
Posted May 26, 2023 - 14:36 CEST
Identified
We are experiencing an increase in mismatches for the Twitter Organic connector.
We have identified the cause of these mismatches and are in contact with Twitter to fix this issue.
Posted May 17, 2023 - 14:19 CEST