Google Looker Studio - Connector not working

Incident Report for Funnel

Monitoring

Google has informed us that: "The issue with Looker Studio has been resolved for all affected customers".

Funnels Google Looker Studio Connector are now working as normal.

We will continue to monitor the situation.
Posted Apr 09, 2026 - 18:40 CEST

Identified

Google has identified that some customers experience errors loading Community Connectors. They are working on mitigating the issue.

We will monitor and update when we have new information from Google.
Posted Apr 09, 2026 - 17:32 CEST

Investigating

There is an issue with Funnels Google Looker Studio Connector not responding and data is not loading in reports.

We are currently investigating the cause.
Posted Apr 09, 2026 - 16:58 CEST