Google Sheets - Data not available in Data Explorer

Incident Report for Funnel

Resolved

This incident has been resolved.
Posted May 26, 2025 - 13:23 CEST

Update

We have deployed a fix and we are currently monitoring the results.
Posted May 15, 2025 - 18:52 CEST

Investigating

We are currently experiencing an issue with displaying data from Google Sheet sources in the Data Explorer. We are investigating the problem.
Posted May 15, 2025 - 18:21 CEST